Google issues vulnerability alert to Chrome Browser users

445

Google has issued a security warning to all its Chrome browser users using its web access platform across Windows, Mac and Linus OSes and has urged people to update to its latest version 81.0.4044.113.

Although the internet juggernaut hasn’t mentioned anything about the vulnerability which could have otherwise exploited by hackers, it did mention that its latest 81st chrome update will fix all the flaws identified to date.

A recent post published in Google Blog says that the details of its security flaws will only be disclosed when a majority of Chrome users have updated to the latest version. And if a bug is found in the 3rd party library the disclosure of the flaw will be further delayed says the post.

Now, to those who desire to see whether they are using the latest version, here’s some help. Just click on the three lines visible at the top of the browser extreme to the right. Hit on those three lines> select help> and then ‘About’ and it will assist you in spotting the version of the Chrome browser you are using.

Meanwhile, the news is out that over 49 malicious chrome extensions were seen emptying the Cryptocurrency wallets as many users were seen losing the keys for their coins.

So, Google is requesting its users to restrict the use of Chrome extensions which are being installed and keep track of those which are already operational.